Summary: information to help you plan your CAST Storage Service / PostgreSQL installation.


Hardware

On-premise

Server typeArchitecture

CPU

RAM

DISK

OS

Notes
Physical/virtual64-bit

Minimum 2 processors:

  • Intel Core i5, 2.6 GHz
  • Intel Xeon, 2.2 GHz

Recommended 4 processors:

  • Intel Core i7, 2.8 GHz
  • Intel Xeon, 2.6 GHz


32GB min

512GB (SSD recommended)

Windows or Linux

CAST highly recommends the use of PostgreSQL on a Linux instance as this consistently gives the best performance.

Cloud services

Amazon Web Services EC2

The following requirements are based on CAST's own testing for the analysis of a single "large Application", using Amazon EC2 R5 Instances:

Minimum instance typeVolume SizeVolume TypeMinimum IOPS
  • r5.xlarge
  • r5d.xlarge
512GBGeneral purpose SSD (gp2) or Provisioned IOPS SSD (io1)400

Amazon Web Services RDS

CAST supports PostgreSQL instances deployed via Amazon Web Services RDS. See also Accessing PostgreSQL on Amazon Web Services RDS.

Supported Operating Systems

Note that CAST highly recommends the use of a Linux Operating System to host a PostgreSQL RDBMS, instead of using the CAST Storage Service on a Microsoft Windows operating system. PostgreSQL installed on Linux has consistently proven to provide better performance than CAST Storage Service installed on Microsoft Windows.

CAST Storage Service

Operating SystemSupportedSupported by ref.Deprecated supportNotes
Microsoft Windows Server 2019(tick)

Installations of Windows Server using only Server Core (i.e. without a GUI) are not supported.

Microsoft Windows 10(tick)


Microsoft Windows Server 2016(tick)

Installations of Windows Server using only Server Core (i.e. without a GUI) are not supported.
Microsoft Windows 8.1(tick)


Microsoft Windows 7 SP1(tick)


Microsoft Windows Server 2012 R2 (Standard edition)
(tick)
Installations of Windows Server using only Server Core (i.e. without a GUI) are not supported.
Microsoft Windows Server 2012 (Standard edition)
(tick)
Microsoft Windows 8
(tick)

Microsoft Windows Server 2008 R2 SP1 (Standard edition)
(tick)

PostgreSQL

Operating SystemSupportedSupported by ref.Deprecated supportNotes
Linux (all recent distributions)(tick)

See the following PostgreSQL documentation for more information:

Supported CAST Storage Service releases

CSS releaseBundled PostgreSQL releaseArchitectureDefault port no.SupportedSupported by ref.Deprecated supportAIP Core compatibilityBundled with AIPNotes
4.13.x13.064bit2284(tick)

AIP Core ≥ 8.3.29-
3.0.13.0.23.0.39.6.1164bit2282(tick)

AIP Core ≥ 8.2.6-
3.0.09.664bit2282(tick)

AIP Core ≥ 8.2.6-
2.0.72.0.89.2.664bit2280

(tick)AIP Core ≥ 7.1.x-From release 2.0.7, CSS has been unbundled from CAST AIP and is provided as a standalone component.
2.0.0 - 2.0.69.2.664bit2280

(tick)AIP Core ≥ 7.1.xAIP Core 7.1.x - 8.2.5
1.0.x8.4.532bit2278(error)

AIP Core 7.0.xAIP Core 7.0.x

Supported PostgreSQL releases

CAST does not provide a custom installer for Linux Operating Systems, however, you can install the following official PostgreSQL RDBMS on to a 64bit Linux Operating System (supported by PostgreSQL) and use it as a storage host for CAST AIP:

PostgreSQL releaseSupportedSupported by ref.Deprecated supportNotes
13.x(tick)

Support is available for PostgreSQL 12.x and 13.x (64bit) as storage, i.e. AIP schemas can be created on this version and analyses will run as expected. Some prerequisites do apply:

  • Minimum required release of CAST AIP core: 8.3.23
  • Minimum required release of specific extensions - same as for PostgreSQL 10.x and 11.x - see below.
12.x
(tick)
11.x(tick)

Support is available for PostgreSQL 10.x and 11.x (64bit) as storage, i.e. AIP schemas can be created on these versions and analyses will run as expected. Some prerequisites do apply:

  • Minimum required release of CAST AIP core: 8.3.16
  • Minimum required release of specific extensions:
JEE Analyzer extensioncom.castsoftware.jee≥ 1.0.19The required minimum releases of these extensions are delivered as "shipped extensions" in AIP 8.3.16.


.NET Analyzer extensioncom.castsoftware.dotnet≥ 1.0.13
SAP BusinessObjects Analyzer extensioncom.castsoftware.businessobject≥ 1.0.4 (LTS)
C and Cpp Analyzer extensioncom.castsoftware.cpp≥ 2.0.5-funcrel-
iOS - Objective-C Analyzer extensioncom.castsoftware.cfamily≥ 1.5.2-funcrel-


10.x
(tick)
9.6.11(tick)

-
9.2.x

(tick)-

CAST Storage Service/PostgreSQL running in encrypted SSL mode

Support is available for connecting to CAST Storage Service/PostgreSQL instances running in encrypted SSL mode. See SSL encrypted mode configuration for CAST Storage Service and PostgreSQL:

CAST AIP core (any application provided with the CAST AIP "core" setup)(tick)≥ 8.3.24
CAST Architecture Checker (standalone)(tick)≥ 1.2.0-funcrel
CAST Dashboards(tick)

≥ 2.0.0-beta1

CAST Imaging (for Source Code configuration)(tick)≥ 2.0.0-funcrel (when using Microsoft Windows traditional installer)
CAST AIP Console (AIP Node)(tick)≥ 1.17.0-funcrel
Sherlock (CAST Support tool)(tick)Sherlock delivered in AIP Core ≥ 8.3.25.

Official CAST AIP Extensions are compatible, however specific minimum releases are required:

JEE Analyzer extensioncom.castsoftware.jee≥ 1.0.28The required minimum releases of these extensions are those that are delivered as "shipped extensions" in AIP 8.3.24.


.NET Analyzer extensioncom.castsoftware.dotnet≥ 1.0.17
SAP BusinessObjects Analyzer extensioncom.castsoftware.businessobject≥ 1.0.6 (LTS)
C and Cpp Analyzer extensioncom.castsoftware.cpp≥ 2.1.0-funcrel-
iOS - Objective-C Analyzer extensioncom.castsoftware.cfamily≥ 1.5.4-funcrel-

Required ports

The following TCP ports must be opened on the server hosting CAST Storage Service/PostgreSQL:

CSS / PostgreSQL release

Listening Port

CSS 4.13.x2284
CSS 3.0.x2282
CSS 2.0.x2280
PostgreSQL ≥ 10.xCustom port (2282/2284 highly recommended)
PostgreSQL 9.6.11Custom port (2282 highly recommended)
PostgreSQL 9.2.xCustom port (2280 highly recommended)