Page tree
Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

« Previous Version 3 Current »

Search in code in an Analysis Service with Subsets

Search in code produces errors when SQL objects are selected in database subsets. As a result, the searched pattern is not found. Search in code works correctly if the SQL objects are not selected in the tree and the search is done in the entire Analysis Service.

Running Enlighten several times

Launching Enlighten twice from the same CAST version (same installation directory) is impossible.

Add Linked Objects

When an Add Linked Objects operation retrieves objects that are currently not in the Object Browser window and you add such an object to the graph without adding its project to the browser (Cancel in the Add Project message box), selecting the Show Full Name check-box will cause all objects to disappear from the Preview list in the Add Linked Objects dialog except for the selected object.

Impact Analysis

FGIA only (Oracle)

  • Please note that only certain client languages are taken into account when calculating an FGIA. Please refer to Enlighten Online Help > Features > Impact Analysis > Calculate Impact Analysis (Column Level/Fine Grain) > What is a Column Level / Fine Grain Impact Analysis? > Oracle Server (FGIA).
  • The FGIA ignores all dynamically constructed queries. For example:On a function f1 containing the following code:

    columnName varchar2(32) := 'C';open myCursor for 'select ' || columnName || ' from theTable';
    

    The FGIA on C will not return the function f1()

  • The FGIA does not take into account the flow control on query calls:On a function f1 containing the following code: if (2+2==5) thenselect C1 into foo from theTable where C1 = 'Foo';elseselect C2 into foo from theTable where C2 = 'Foo';end if; An FGIA on C1 will correctly return f1 whereas the test (2+2=5) is never correct.Please note that the equivalent CLIA feature on MS-SQL servers does carry out this type of dynamic analysis, and will behave correctly in the aforementioned examples.

FGIA (Oracle) & CLIA (SQL-Server)

  • Sometimes objects with a different impact level (IMPLEVL) are drawn on the same line (level) on the view. This can occur for an object with two impact levels (e.g. 1 and 2); in this case the object is drawn on the line for level 1. This can also occur when a parameter is impacted; the impact analysis engine counts an impact on a parameter as a separate level, but Enlighten does not display the parameter as an object by itself and the object containing the parameter is drawn on the "wrong" level.
  • Carrying out a CLIA/FGIA on light imported tables may not return accurate results.
  • Neither the CLIA (when using a Microsoft SQL Server) nor the FGIA (when using an Oracle Server) takes into account indexes:

No CLIA/FGIA results will be issued about indexes containing a modified column (whether this column is a table column or a view column). In addition, in scripte of procedures, triggers, functions or views, no CLIA results will be issued about names of indexes containing a modified column. For example, on a Microsoft SQL Server, where the CLIA job is the simulation of the removal of "T.C1", no impact will be reported about I or P, despite the fact that in this latter case the index hint « WITH( INDEX( I ) ) » becomes obsolete.

CREATE TABLE T ( C1 int, C2 int )
CREATE INDEX I on T ( C1, C2 )
CREATE PROCEDURE P AS SELECT * FROM T WITH( INDEX( I ) ) WHERE C1 = 1

Object Browser

  • When an object is shared by multiple analyses and appears more than once in the Object Browser window, the Find in Browser feature finds only one object.
  • Enlighten configures itself at startup to support all programming languages for which objects are present in the Knowledge Base. If you analyze a language not yet present while Enlighten is running, you cannot display the resulting objects unless you close and reopen a new view. In some cases it is even necessary to restart Enlighten.
  • Selecting the option Display Parameters in the Object Browser configuration tab (Tools > Options > Browser) may cause the Object Browser window to take some time to refresh - particularly if you have a large Knowledge Base that contains a lot of information.
  • The number of projects you can load into the Object Browser is limited to 50 projects. Enlighten can close unexpectedly if you exceed this limit. 50 projects is an approximate value. The exact limit depends on the number of objects and their hierarchy structure inside the projects. You load projects into the Object Browser either during Initial Scope Selection, when adding linked objects to the view and the objects' project is not loaded already, or through the command Load Project into Object Browser.
  • After analyzing a new .NET job with two csproj - Project1 and Project2 - and Project2 depends on Project1, and the analysis order was Project2 before Project1, then the Namespaces folder in the Object Browser under Project2 contains both, source code objects and external objects.

Display Configurator

  • When creating a sub-view from a parent view, rules defined in the Display Configurator for the parent view are not active in the sub-view.
  • The Display Configurator does not function with Generic Objects (links between these object types cannot be ignored).

Code Viewer Bookmarks

  • If a bookmark in Code Viewer is on the first line of code of the object, the bookmark is shifted by one character.
  • The Code Viewer (when displaying code that forms part of a .NET Analyzer analysis) will display erroneous bookmarks for links between Constructors and Fields. Typically, the bookmark will be displayed outside the Constructor on the initialization of the field.
  • Bookmarks in files of .NET applications are on the entire line whereas for other languages bookmarks also specify the column causing a link. In addition, bookmarks for inherited links and for links between a dataset and a server object are always on the first line of the class.

Business Function/Comment

This application allows you to enter for documentation purposes a label for each object by right-clicking on it on a view, pointing to Advanced and selecting the command Business/Comment/Label. Please note that the following CAST Analyzers override this label when re-analyzing an application: PL/SQL (with the object comment as defined in the Oracle Data Dictionary), PB (with the PowerBuilder internal label), VB (with the caption in the case of VB controls), JSP (an existing label is replaced by a space ' '), T-SQL (with the label "imported" or "synchronized").

Search in code

  • When using a Microsoft SQL-Server or Sybase ASE server (regardless of the version), the Search in Code feature is not available for table indexes and table constraint names.
  • Other limitations are described in the Search in Code section itself. See Limitations (Search in Code) in the Enlighten online help for more details.

Cost Estimation

The Cost Estimation feature in Enlighten is based on CAST Dashboard technology. Therefore the same limitations apply as for the CAST Dashboard.

  • The "Cost Complexity" metric ("COST_CPLX_COMPUTE") is calculated only for artifacts containing source code.
  • It is not possible that more than one user runs a Cost Estimation at the same time on the same Knowledge Base. If you do so, you will get an error message in the Enlighten log. When the Knowledge Base is on Microsoft SQL Server, the error is: "SQL error: Cannot find the object "ENVISION_EFFORT_STATS" because it does not exist or you do not have permissions"
  • It is not possible to run a Cost Estimation, while a Snapshot is calculated by AD Administration on the same Knowledge Base because this creates conflicts on tables used by both operations.

Path Finder

Path Finder stops calculating paths after about 2 minutes to not have the user wait too long for the results. Only paths found within this time are displayed. No path is displayed, even if a path might exist between two objects, when finding this path would take more than 2 minutes.

Filter Profile Manager

The default file path in the Profile Builder dialog box is a temporary folder. Therefore, when saving a new filter profile to the default path, the profile will have disappeared when opening Enlighten the next time. To avoid this, change the default file path using the Browse button in the Profile Builder dialog box and choose a permanent folder, e.g. My Documents. You access the Profile Builder dialog box choosing Tools > Profile Manager > New.

Miscellaneous

  • If you analyze a C++/Java/ASP project when Enlighten is open and running, some undesirable effects may occur. Carrying out a refresh on the Graphical View (F5) will restore a coherent display state.
  • Locate in Technical Browser is limited to 20,000 parentships.
  • Expand Children is limited to 50,000 children.
  • Positions of access types of links are not saved, when saving a view. Therefore, when you have changed the position of an access type of a link and then saved and closed the view, the access type will occur at its default position when re-opening the view. The access type of a link is letter combination drawn next to the link indicating in what way the calling object accesses the called object, for instance "Us".
  • No labels